Is it support python 2.7 and 3.4 ?

Solved!
Posted in General by kwang nam Sun Jul 26 2015 13:37:03 GMT+0000 (UTC)·4·Viewed 1,704 times

Hi I tested your packages and got a problem , It works well on Python 2.7 but not on Python 3.4 like this when use Python 3.4 from . import version ImportError: cannot import name 'version' ERROR: Module: test.opendeeptest could not be imported (file: E:/project_luna/cuda/open_deep/test/opendeeptest.py). Importing test modules ... done. Any suggestion ?
Markus Beissinger
July 26, 2015

I tried a hotfix for the version import errors (worst case it compiles and reads from the version file directly). Pull the latest version from GitHub and let me know if it works!


Markus Beissinger marked this as solved
kwang nam
July 27, 2015

Hi thanks for your quick response,
First, I am newbie on Python , it can be my setting fault

I tried it run sample code, but I still got erros

such as RawInstreamFile.py
you just did like this

from DataTypeConverters import readBew, readVar, varLen

interprinter compalins can't find it
So changed like this

from opendeep.utils.midi.DataTypeConverters import readBew, readVar, varLen

I found many places that have same problems

2) my sample code is this

config = {
"outdir": 'outputs/dae/mnist/',
"input_size": 2828,
"tied_weights": True
}
dae = DenoisingAutoencoder(*
config)

and I got this error

Traceback (most recent call last):
File "E:\project_luna\cuda\open_deep\test\opendeeptest.py", line 39, in <module>
dae = DenoisingAutoencoder(config)
File "F:\python34\python-3.4.3.amd64\lib\site-packages\opendeep-0.0.9a0-py3.4.egg\opendeep\models\single_layer\autoencoder.py", line 152, in init
{arg: val for (arg, val) in locals().iteritems() if arg is not 'self'}
AttributeError: 'dict' object has no attribute 'iteritems'

Any Idea ?

kwang nam
July 27, 2015

Oh the first error doesn't happend
thx

Markus Beissinger
July 27, 2015

Thanks for helping me find these python 3 errors! I fixed up the test examples if you want to pull the latest version; it should work now. I'm also in the process of updating the documentation here since the latest version refactored a lot of things (like the way datasets work). Let me know if you run into any more errors!

Markdown is allowed